Not a developer? Go to MovableType.com

News

Movable Type 5.02 patch to fix the Publish Queue

By Jun Kaneko
Posted May 21, 2010, in MT5.

Thanks to the report, we found and fixed an issue in Movable Type 5.02.

Movable Type 5.02 has an error in Publish Queue for archive templates. This error occurs when you publish your archive templates via Publish Queue. Run-periodic-tasks doesn't publish archive templates properly. Only index templates are published.

Please download the patched code from the release notes, and follow the instructions to put it in place.

Back

13 Comments

PRO IT Service

PRO IT Service on May 21, 2010, 2:04 a.m. Reply

I’ve noticed a similar issue with the Archive Templates that occurs also with movable type v4.34, but not with PublishQueue, instead with Tim Appnel’s mt-rebuild.pl plugin.

When the Archive Templates are set to “statically publishing”, the mt-rebuild.pl plugin works with mt v4.34.

However, if I set the Archive Templates to “manually publishing”, Tim’s plugin doesn’t work anymore.

Tim mentioned this seems to be an issue with movable type v4.34 internal coding, but he is going to investigate more on this and eventually come up with a fix.

Jun Kaneko

Jun Kaneko on May 23, 2010, 6:47 p.m. Reply

Hmm.. sounds strange. Please let me know if there is something in the core !

PRO IT Service

PRO IT Service on May 24, 2010, 7:06 a.m. Reply

I’m going to file a bug report for this issue (movable type v4.34).

Dave Aiello

Dave Aiello on May 28, 2010, 7:01 p.m. Reply

Mihai: FYI, the code in the checkin related to the Movable Type 5.02 patch isn’t the same as the code that’s currently in Movable Type 4.34. So, it’s probably not the same bug if there is a bug in 4.34 as you’ve suggested.

demonsurfer

demonsurfer on June 2, 2010, 7:25 p.m. Reply

Does the full 5.02 download include the patch (for those who have not upgraded from 5.01 yet)? ..or do we need to upgrade to 5.02, and then patch it..

Jun Kaneko

Jun Kaneko on June 2, 2010, 9:49 p.m. Reply

5.02 does not include this patch. Please apply the patch after your upgrade. I’m sorry for your inconvenience .

demonsurfer

demonsurfer on June 3, 2010, 8:07 p.m. Reply

No problem. Thank you.

demonsurfer

demonsurfer on June 3, 2010, 8:17 p.m. Reply

Some nice surf pics on your site.. I lived in Hamilton (NZ) for 8 years and surfed Raglan almost every week (Whale Bay and Indicators mostly). Some of the other pics on your blog.. is that Gisborne (I don’t read Japanese sorry)? I lived in Gisborne off and on for about a year also. Now I live in New York.. surf here sucks. :-/ Hang loose.

Jun Kaneko

Jun Kaneko on June 4, 2010, 5:31 a.m. Reply

Hello damonsurfer,

Indeed the pictures are from New Zealand ! I went to Gisborne and Raglan in May, and surfed there. I’m quite surprised and happy to see a surf buddy here :)
It was my first trip to New Zealand, and I loved the country. Surf Raglan ever week … that’s what I’m dreaming everyday now back in Tokyo. I have more photos on Flickr and Youtube. See you there if you don’t mind !

aiden

aiden on July 14, 2012, 12:44 p.m. Reply

Thank you for the update. I am going to make the changes. Nice pictures, though. I like them too.

Anna Colova

Anna Colova on October 24, 2012, 9:59 p.m. Reply

Hi Jun I was interested from the Demonsurfer comment and I took a look on your site. I am interested in something different. Why the index page of your site is on Japanes, but the inner pages on English?

Kevin Cole

Kevin Cole on November 13, 2012, 4:18 p.m. Reply

Hi, I can’t find any info about this bug in FogBugz. Is it possible to give me link to it, because I am really interested about the solution?

Ines

Ines on November 23, 2012, 1:54 a.m. Reply

Mihai, what happened with problem you have found with Movable Type 4.34? Is it fixed and if it is where can we find some information about it?

Leave a Comment