Not a developer? Go to MovableType.com

Ask an Expert

Need to upgrade

Asked by Anne Zook
Posted November 26, 2013.

I’m running an old version of MT (V2.64 has been my blog platform since 2011) and know I need to upgrade to a newer version.

I’m worried that it will be beyond me to do this since I’m not very technology-savvy.

Back

Give an Answer

Ask An Expert